> >

Post New Thread  Reply
 
Thread Tools
Old 06-18-11, 02:42 AM   #29
Newcomer
Join Date: Jun 2011
Posts: 1
I cannot add the plugin it says toplevel.py is missing
tokey is offline   Reply With Quote
Old 07-21-11, 03:48 AM   #30
She Dragon Extraordinaire

Join Date: Jan 2010
Location: In the bowels of the Earth
Posts: 2,669
From The developers of these tools on their blog-

Quote:
Amazon is now getting nasty about DRM.

In the space of a few short months, their developers have completely revamped their “secure storage” of the information needed to remove the DRM on both of their Kindle for PC and Kindle for Mac applications.

They have now added code to their Kindle application that tries to prevent a debugger from attaching, detects when a debugger is being used, and literally changes the path the code takes on the fly depending on whether the process with that pid is being debugged or not. So any use of a debugger will result in deliberately incorrect information/code paths being selected with incorrect data DRM data being used which will result in ebooks that won’t open triggering the need to “re-register” with Amazon.

It has been a good fight to protect our fair use rights, but given the fast approach of encrypted binaries and sandboxing, coupled with now active detection/counter-measures for using a debugger, it is a fight we are very soon going to lose. I hope Amazon and others like them are proud of themselves.
my note-
I may stop purchasing from Amazon and start getting epubs from B&N.

Last edited by bookdragon; 07-21-11 at 03:53 AM.
bookdragon is offline   Reply With Quote
Old 08-10-11, 04:27 PM   #31
Novice
Join Date: Sep 2009
Posts: 127
Dumb question here. This so, I can use the plug ins. For instance I bought a EPUB and I have ADE in my computer, and a MOBI so what do I have to use? thanks.

by the way, I did not bought from amazon, nor barnes, but from other stores.

Last edited by sjak; 08-10-11 at 04:32 PM.
sjak is offline   Reply With Quote
Old 09-10-11, 10:11 AM   #32
She Dragon Extraordinaire

Join Date: Jan 2010
Location: In the bowels of the Earth
Posts: 2,669
New tools posted in OP with support for AZW4 files. (non rented)

A small set of users, primarily Mac OS X 10.5 PowerPC users, are stuck with using older versions of Calibre because newer versions of Calibre have dropped support for their platform. The Calibre plugin API has changed which means the Calibre plugins provided by the most recent tools releases will not work on older versions of Calibre. Here are old API plugins

bookdragon is offline   Reply With Quote
Old 09-26-11, 05:26 AM   #33
Novice
Join Date: Jul 2009
Posts: 123
Thank you very much!
vlefteris is offline   Reply With Quote
Old 10-07-11, 08:52 AM   #34
Newcomer
Join Date: Oct 2011
Posts: 2
worked a treat for me. thanks SO much bookdragon
gazza341 is offline   Reply With Quote
Old 10-12-11, 07:22 PM   #35
Newcomer
Join Date: Aug 2011
Posts: 78
Yes, this does work for B&N epub files. I'd gotten this set of tools from another forum with different and incorrect text file directions. Just changing my cc info to it's full number, rather than the 8 digits I was told on that forum made it work without even deleting the plug-ins. Many, many thanks!! :)
hurtgirl is offline   Reply With Quote
Old 10-30-11, 01:11 PM   #36
She Dragon Extraordinaire

Join Date: Jan 2010
Location: In the bowels of the Earth
Posts: 2,669
Quote: Originally Posted by hurtgirl View Post
Yes, this does work for B&N epub files. I'd gotten this set of tools from another forum with different and incorrect text file directions. Just changing my cc info to it's full number, rather than the 8 digits I was told on that forum made it work without even deleting the plug-ins. Many, many thanks!! :)
Happy to help updated tools posted today.
bookdragon is offline   Reply With Quote
Old 10-31-11, 06:29 AM   #37
Newcomer
Join Date: Oct 2011
Posts: 1
Hello,

I am new here. I downloaded the zip-file from this link in the OP

When I want to unpack the file, I get an error message. Do I have to unpack to a specific directory, or is there something wrong with the zip-file?

Last edited by Kaahdeeh; 11-01-11 at 05:06 AM.
Kaahdeeh is offline   Reply With Quote
Old 10-31-11, 06:12 PM   #38
Newcomer
Join Date: Nov 2010
Posts: 3
Default Zip file is broken!

I downloaded the updated (4.8) files from both upload locations on multiple computers with the latest stable version of winrar. Both unzip with errors 100% of the time. Can you please rezip and reupload. Thanks for your efforts.
tbdawg is offline   Reply With Quote
Old 10-31-11, 07:23 PM   #39
She Dragon Extraordinaire

Join Date: Jan 2010
Location: In the bowels of the Earth
Posts: 2,669
Quote: Originally Posted by tbdawg View Post
I downloaded the updated (4.8) files from both upload locations on multiple computers with the latest stable version of winrar. Both unzip with errors 100% of the time. Can you please rezip and reupload. Thanks for your efforts.
I am truly sorry! I reupped and then downloaded and tested the uploads. They are now working. I was having connectivity issues during upload last night and the problems may have corrupted the file.
bookdragon is offline   Reply With Quote
Old 10-31-11, 08:19 PM   #40
Newcomer
Join Date: Nov 2010
Posts: 3
NP, Thanks Again!!

Edit:

Well I just dl'ed them again and I get a new error:
C:\...\tools_v4.8(1).zip: CRC failed in tools_v4.8\DeDRM_for_Mac_and_Win\DeDRM_3.1.app.zip . The file is corrupt

Tried from both dl locations and get same above ^^ error. The rest of the files extracted just fine.

Last edited by tbdawg; 10-31-11 at 08:55 PM. Reason: Zip File Still Corrupted!
tbdawg is offline   Reply With Quote
Old 11-01-11, 04:34 AM   #41
She Dragon Extraordinaire

Join Date: Jan 2010
Location: In the bowels of the Earth
Posts: 2,669
Quote: Originally Posted by tbdawg View Post
NP, Thanks Again!!

Edit:

Well I just dl'ed them again and I get a new error:
C:\...\tools_v4.8(1).zip: CRC failed in tools_v4.8\DeDRM_for_Mac_and_Win\DeDRM_3.1.app.zip . The file is corrupt

Tried from both dl locations and get same above ^^ error. The rest of the files extracted just fine.

They are now in a rar file. I checked the previous upload just by opening the zip. This time I checked by actually extracting the files and everything worked fine. It seems the problem had something to do with keeping the same link and just updating the files. I have been doing it this way since I started the tread. Yet even changing from zip to rar left me with a corrupt rar file after download when I just updated the files. I had to delete the existing file and upload the new version before I got a clean download. The links in the OP have now been updated. I am truly sorry for all the problems.
bookdragon is offline   Reply With Quote
Old 05-02-12, 07:26 PM   #42
She Dragon Extraordinaire

Join Date: Jan 2010
Location: In the bowels of the Earth
Posts: 2,669
New Tools Updated May 2012 Version 5.0 See 1st post for link

***Important Note for Calibre Users***
Many of the ebooks you purchase via the latest Kindle for PC and Kindle for Mac versions 1.9.X or later may use the new KF8 format. Although removal of the DRM will work just fine for these ebooks, Calibre does not yet understand KF8 ebooks and so will not correctly display them or correctly convert them. So until the developers of Calibre fix this issue, if you want to display and convert KF8 ebooks, we recommend using the Mobi_Unpack tool on the no-drm version of the KF8 ebook and using the .epub file it creates for viewing on other platforms and converting to other formats.
bookdragon is offline   Reply With Quote
Reply


Thread Tools



All times are GMT -7. The time now is 08:07 AM.
SEO by vBSEO ©2011, Crawlability, Inc.